Degraded Functionality: Email Sender
Incident Report for Total Expert
Resolved
This issue has been resolved.
Posted Mar 06, 2024 - 12:15 CST
Investigating
We are currently experiencing an issue that is preventing the recipient list from loading properly when sending an email through the Email Sender page.
Posted Mar 06, 2024 - 10:18 CST
This incident affected: Core Platform (Email Messages).