Group Creation and Editing

Incident Report for Total Expert

Resolved

Full functionality has been restored for creating and editing Groups. This incident has been resolved.
Posted Apr 02, 2026 - 13:39 CDT

Identified

We are currently experiencing an issue that is preventing users from creating or editing Groups and causing inconsistencies in UI visuals on the Groups page. Our engineering team has identified the cause and is actively working on a fix. We will provide updates as more information becomes available and we appreciate your patience while we resolve this issue.
Posted Apr 02, 2026 - 12:52 CDT
This incident affected: Core Platform (Web Application).